1. ¿Buscando un Banco para abrir tu primera cuenta de ahorros? Revisa nuestro comparativo de cuentas cero mantenimiento haciendo clic aquí.
    Ocultar anuncio

Activación de elementos ActiveX

Publicado en 'Webmasters' por x-web, 21 Nov 2006.





  1. x-web

    x-web Miembro maestro

    Registro:
    23 Set 2006
    Mensajes:
    303
    Likes:
    0




    Hola:

    Bien a estas altura todos deben saber el problema que existe con IE y los contenidos embebidos ActiveX como peliculas flash, Applets, Videos de media player.

    Pues una solución para esto es utilizar código Javascripts uno de lso mas usados es SWFObject el funciona bien pero tiene el incoveniente (al menos para mi) de tener que actulizar con su código cada flash que tengas en una página, lo cual ya es trabajo extra.

    Una alternativa para esto es este código Javascrips (que por cierto no tiene nombre JS Embedded Content por su autor) la gran ventaja para empesar es que solo es necesario ingresar una linea de código, la que necesitamso que insertar el archivo JS en el documento y listo

    Palabras del Autor
    JS Embedded Content" es una pequeña aplicación Javascript que permite la
    activación automática de los elementos OBJECT, EMBED y APPLET incrustados
    en un documento HTML (películas Flash, applets de Java, archivos de video,
    etc.); de esta manera se evita que estos elementos deban ser activados
    manualmente por el usuario, porcedimiento necesario para que pueda interactuar
    con ellos en Internet Explorer 7, algunas actualizaciones de Internet Explorer 6 y en algunas versiones de Opera 9.


    Para descargar
    Descargar script (versión 1.1 final)


    PD: el Autor (David Muñoz) me a comentado que no hay una web oficial del código de momento por lo que no hago referencia a ninguna WEB
     


  2. MijT

    MijT Miembro de bronce

    Registro:
    12 Oct 2006
    Mensajes:
    1,106
    Likes:
    63
    x-web el link para descargar ese archivo esta roto :question: :unsure:
     
  3. Goku

    Goku Miembro de bronce

    Registro:
    23 Set 2006
    Mensajes:
    1,646
    Likes:
    86
  4. x-web

    x-web Miembro maestro

    Registro:
    23 Set 2006
    Mensajes:
    303
    Likes:
    0
    Siento lo del enlace, es posible que se actualizara.

    Goku podrias explicar un poco mas sobre tu problema, te refieres que no funciona usando el código JS Embedded Content, podrias mostrar parte del código usando en tu página.

    Saludos
     
  5. Goku

    Goku Miembro de bronce

    Registro:
    23 Set 2006
    Mensajes:
    1,646
    Likes:
    86
    Holas,

    El código es:

    Código:
    <object width="425" height="350">                    <param name="movie" value="http://www.youtube.com/v/HA4P_0VCeuQ"></param><embed src="http://www.youtube.com/v/HA4P_0VCeuQ" width="425" height="350" align="middle" type="application/x-shockwave-flash"></embed></object>
    Y está insertado en el documento HTML del artículo "Conociendo los Blogs". El problema es que cuando intento reproducir el vídeo de YouTube integrado en IE y le doy "play" termina inmediatamente y dice "Play again" y "Share". Osea no llega a reproducir nada.

    El mismo problema sucede cuando intento ver los vídeos integrados de YouTube en el foro usando IE. Con Firefox no hay problemas.

    Alguna sugerencia? :(
     
  6. Wilssonly

    Wilssonly Suspendido

    Registro:
    16 Oct 2006
    Mensajes:
    450
    Likes:
    0
    Yo veo el video sin ningun problema en IE6, o acaso te refieres al IE7??
     
  7. Goku

    Goku Miembro de bronce

    Registro:
    23 Set 2006
    Mensajes:
    1,646
    Likes:
    86
    Uhm... no, yo me refería al IE6 que viene con el SP2 de Windows XP.

    Aparentemente es un problema de mi PC, habrá que verlo... aunque para qué verlo si ya no uso el IE :P
    Creo que los webmasters sólo usan el IE para adaptar el código de sus páginas a este navegador tan especial ¬¬
     
  8. x-web

    x-web Miembro maestro

    Registro:
    23 Set 2006
    Mensajes:
    303
    Likes:
    0
    A mi se me ve bien Goku, por cierto en los ultimos días cada vez que entro en S.O me salta el mensaje "exiisten actualizaciones pendientes" y todo el rollo a pesar que tenia las actualizaciones automaticas y resulta que la actualización es para pasar el IE6 al la versión 7, nose si a alguien mas le a pasado:unsure:


    Saludos:)
     
  9. MijT

    MijT Miembro de bronce

    Registro:
    12 Oct 2006
    Mensajes:
    1,106
    Likes:
    63
    pues a mi no me ha pasado, pk yo instale el IE7 por mi cuenta