Ayuda

Publicado en 'Programación' por ZubZero, 4 Jun 2011.





  1. ZubZero

    ZubZero Miembro frecuente

    Registro:
    4 Jun 2011
    Mensajes:
    77
    Likes:
    30




    - Buenas amigos recien estoy estudiando algoritmos queria saber si me pueden ayudar con estos algoritmos que son de vectores:

    1. Elabore un algoritmo que nos devuelva el minimo de los valores incluidos en un vector.
    2. Elabore un algoritmo que nos devuelve el elemento que mas se repite de los valores incluidos en el vetor.
    3. Leer una secuencia de numeros, almacenarlas en un vector y mostrar el mayor de los multiplos de 5 leidos y el menor de los multiplos de 3 leidos.
    Es de vida o muerte :cray:
     


  2. ZubZero

    ZubZero Miembro frecuente

    Registro:
    4 Jun 2011
    Mensajes:
    77
    Likes:
    30
    nadie ? help me :cray:
     
  3. erickxls

    erickxls Miembro maestro

    Registro:
    13 Set 2008
    Mensajes:
    842
    Likes:
    15
    una sugerencia no pongas un titulo generico como AYUDA pon una descripcion de tu problema y otra deberias mostrar los avances que tengas no simplemente pedir que te hagan la tarea
    te ayudo en uno el primero
    asumiendo un vector v[n]
    int min=v[0];
    for(int i=1;i<n;i++){
    if(v<min)
    min=v;
    }
     
    Última edición: 5 Jun 2011
    A carlitosfriend, ZubZero y Bizos77 les gustó este mensaje.
  4. ZubZero

    ZubZero Miembro frecuente

    Registro:
    4 Jun 2011
    Mensajes:
    77
    Likes:
    30
    gracias brother lo tendre en cuenta :)
     
  5. johannAV

    johannAV Miembro frecuente

    Registro:
    1 Mar 2011
    Mensajes:
    69
    Likes:
    4
    ¿lenguaje?
     
  6. celsoxvi

    celsoxvi Miembro de bronce

    Registro:
    1 Mar 2009
    Mensajes:
    1,196
    Likes:
    72
    Esta estudiando algoritmos, a lo mucho que necesitara es el Diagrama de Flujo :D, pero seria buen que especifiques :D
     
  7. ZubZero

    ZubZero Miembro frecuente

    Registro:
    4 Jun 2011
    Mensajes:
    77
    Likes:
    30
    Si este curso recien estoy ke llevo primera ves que veo este curso y la verdad me ha chokado un poco inicialmente me piden en pseudocodigo ya el resto es mas facil por eso pedia ayuda de todas maneras gracias a todos,:hi:

    ----- mensaje añadido, 09-jun-2011 a las 21:09 -----



    Gracias brother :hi:
     
    Última edición: 9 Jun 2011
  8. robert_007

    robert_007 Miembro frecuente

    Registro:
    3 Ene 2011
    Mensajes:
    161
    Likes:
    37
    Haber Te voy a ayudar con la 3 :

    INICIO
    Var entero N, num [100], min3, may5
    min3=num [0]
    may5=num [0]
    Lectura(N, num)
    Proceso(N, num, min3, may5)
    Mostrar (min3, may5)
    FIN

    Modulo Lectura (Ref. entero N, Ref. entero num [100])
    INICIO
    Var entero i
    Repetir
    Leer N
    Hasta que (N> 100)
    Para x=0 hasta x=N-1 de 1
    Leer num
    fin_para
    FIN

    Proceso (Valor entero N, Ref. entero num [100], Ref. entero SP, Ref. entero SI, Ref. entero PM)
    INICIO
    Var entero x, i, min3, may5
    min3=num [0]
    may5=num [0]

    Para x=0 hasta x < =N de 1
    Si (num [x] mod 5 ==0) entonces
    Si (num [x] >may5)
    may5=num
    fin_si
    fin_si
    Para i=0 hasta i < =N de 1
    Si (num [x] mod 3 ==0) entonces
    Si (num [x] <min3)
    min3=num
    fin_si
    fin_si
    fin_para
    FIN

    Modulo Mostrar (Valor entero SP, Valor entero SI, Valor entero PM)
    INICIO
    Escribir “Mayor de los múltiplos de 5”, may5
    Escribir “Menor de los múltiplos de 3”, min3
    FIN

    Saludos :yeah:
     
    Última edición: 14 Jun 2011
    A carlitosfriend le gustó este mensaje.