conpatibilidad de un MIDlet

Publicado en 'Programación' por raul_tino, 28 Ago 2010.





  1. raul_tino

    raul_tino Miembro nuevo

    Registro:
    15 Mar 2010
    Mensajes:
    7
    Likes:
    0




    estoy comenzando a programar aplicaciones para celulares, los llamados MIDlets y hace una semana y bueno estoy usando netbeans he hecho los clásicos hola mundo y otras pequeñas aplicaciones, mi problema comenzó cuando lo compilo y genero el .jar y .jad y lo introduzco a mi celular que es un W700 no corre la aplicación y no he dado hasta ahora con la solucion e estado investigando y creo que algo relacionado a la configuración, podrían ayudarme por favor debo buscar plugins para el MIDlet para que sea compatible con sony ericsson o me equivoco ?
     


  2. bebito_agu

    bebito_agu Miembro de bronce

    Registro:
    21 Oct 2008
    Mensajes:
    1,131
    Likes:
    56
    No te puedo dar mayor ayuda porque no programo, pero creo que debes revisar la resolución de la pantalla de tu celular y la resolución de pantalla de tu MIDlet. DE eso también depende que funcione o no en tu celular.
     
  3. aroldognr

    aroldognr Miembro maestro

    Registro:
    14 Feb 2010
    Mensajes:
    329
    Likes:
    21
    Buscate emuladores para sony ericcsson y prueba alli tus aplicaciones.
    no se si me equivoque.:hi:
     
    Última edición: 30 Ago 2010
  4. gustavocc

    gustavocc Miembro nuevo

    Registro:
    18 Jul 2010
    Mensajes:
    23
    Likes:
    1
    Cuando creas el proyecto MIDlet, tienes que escoger el tipo de tu celular. Si es NetBeans, cuando estas creando el proyecto (poniendo nombre, paquete), te sale "Default plataform Selection", no estoy seguro de que plataforma es tu celular pero podrias probar primero con DefaultCldcjtwiPhone2. Prueba con uno de esos o averigua que plataforma es tu celular. O en todo caso instala el SDK de la misma Sony, con eso lo solucionas, aqui te dejo el link:

    http://developer.sonyericsson.com/w...loads/docstools/1.706816/1.706818?cc=gb&lc=en
     
  5. raul_tino

    raul_tino Miembro nuevo

    Registro:
    15 Mar 2010
    Mensajes:
    7
    Likes:
    0
    voy probar y de ahi posteo gracias gustavocc

    ----- mensaje añadido, 10-sep-2010 a las 00:01 -----

    a mi cel es un sony ericsson w700 ah..y me es mas sencillo trabajar con el IDE netbeans y con respecto a usar el SDK de sony ya lo habia bajado pero no me gusto creo que fue un error no haber hecho una aplicacion ya teniendo el SDK de sony (mea culpa) pero me parece mejor netbeans aparte trabajo en linux y me es mas sencillo de utilizarlo, voy a probar tu primera sugerencia
     
  6. gustavocc

    gustavocc Miembro nuevo

    Registro:
    18 Jul 2010
    Mensajes:
    23
    Likes:
    1
    Claro revisa que plataforma es tu celular. Por ejemplo yo tengo un Nokia 3500 y en las propiedades de mi telefono puedo ver que plataforma es, por ejemplo me sale
    perfil :MIDP-2.0
    configuracion : CLDC-1.1

    En la parte de Netbeans donde se escoge plataforma, justamente sale unas opciones debajo donde tienes que marcar el perfil y la configuracion. Solo bastaria con marcar las de tu celular. Saludos