Editor Visual basic excel 2010 urgente!!!!

Publicado en 'Programación' por xeros, 2 Ago 2013.





  1. xeros

    xeros Miembro nuevo

    Registro:
    5 Dic 2008
    Mensajes:
    20
    Likes:
    0




    hola bueno necesito ayuda con este tema

    tengo una base de datos con los campos
    n° de cuenta
    dni
    estado

    muy simple la base pero quiero que cada ves que ingrese los datos haya una busqueda automatica que me verifique si hay duplicados solo en el campó n° de cuenta con su respectivo msgbox "n° de cuenta duplicado" solo eso.... quiero que sea automatico sin macro porq se pierde mucho el tiempo ejecutandola...

    si alguien puede ayudarme con este codigo se lo agradecere
     
    Última edición: 2 Ago 2013


  2. PedroBetancour

    PedroBetancour Miembro nuevo

    Registro:
    14 Ago 2012
    Mensajes:
    42
    Likes:
    1
    yo te ayudo con una formula....ten en una columna al costado de tus datos la formula
    =contar.si(rango,criterio)

    Esta formula tiene q hacer referencia a la celda donde tipearas el DNI (eso sería el "criterio") y toda la columna donde estan los DNIs (eso es el rango , para que selecciones todo la columna A por ejemplo pones A:A), sabras que un DNI esta repetido si el valor que te aparece es 2 y no 1( 1 esl valor aparece 1 vez, 2 es xq esta dos veces, etc)

    EJ:si el DNI esta en la columna "b"
    =CONTAR.SI(B:B,B2)
     
    Última edición: 2 Ago 2013
  3. xeros

    xeros Miembro nuevo

    Registro:
    5 Dic 2008
    Mensajes:
    20
    Likes:
    0
    gracias amigo pero esa formula ya la estoy usando, lo que quiero es automatizarla mas con el editor visual basic en el cual lleva codigo parecido a este:

    Private Sub BusquedaDup(ByVal target As Range)
    Application.EnableEvents = False

    If Not Intersect(target, Range("B2:H920")) Is Nothing Then
    MsgBox("Este dato ya existe, verificar"), vbcritical
    Call MarcarDup
    End If

    Application.EnableEvents = True
    End Sub



    por alguna razon no me funcionaaaaaaaaa
     
    Última edición: 2 Ago 2013