GTK+ y retrocompatibilidad

Publicado en 'GNU/Linux' por chillinfart, 19 Abr 2013.





  1. chillinfart

    chillinfart Miembro de oro

    Registro:
    23 Ene 2011
    Mensajes:
    6,402
    Likes:
    2,220




    Bueno, buscando algunos aplicativos me hallo en la necesidad de saber algo. La distro que uso actualmente (Slacko 5.5) usa GTK+2, pero algunos aplicativos que necesito usar se estancaron en el pasado y usan la vieja versión (GTK+). La última vez que me tocó pasar un problema así fue con un emulador de PowerPC (Sheepshaver) y no me quedó otra que usarlo por comandos.

    ¿Si lo compilo desde cero afectará la instalación actual? ¿Hay alguna forma para que ambos coexistan?.
     


  2. zchronos

    zchronos Miembro maestro

    Registro:
    12 Dic 2008
    Mensajes:
    312
    Likes:
    151
    Esa versión es demasiado antigua, actualmente van por la número 3.

    Siendo sincero dudo mucho que el simple hecho de cambiar las librerías de gnome sea suficiente, es posible que también funcione con otras viejas versiones de librerías de sonido y quizás hasta obsoletos módulos del kernel.

    Lo mejor que puedes hacer es buscar una distribución antigua, así lo compilas sin problemas. Otra alternativa es buscar otro programa similar pero que sea más actual. La última solución es bajar el código fuente, analizar la lógica de la programación y luego tú mismo programar todo desde 0 (suerte con eso).
     
Etiquetas: