Intellisense para clases en Sublime Text 3

Publicado en 'Programación' por eduar2083, 8 May 2016.





  1. eduar2083

    eduar2083 Miembro frecuente

    Registro:
    26 Jul 2011
    Mensajes:
    224
    Likes:
    46




    Hola,
    Quiero que el editor me sugiera clases según las vaya escribiendo. He instalado el package SublimeCodeIntell pero no me funciona.

    Favor su apoyo, muchas gracias.
     


  2. CarCaBot

    CarCaBot Miembro maestro

    Registro:
    25 Nov 2011
    Mensajes:
    503
    Likes:
    215
    Ya sabes programar bien? Aunque no es mi editor favorito he completado la tarea de probar instalar el paquete y si va bien. Q problema te da?
     
    Última edición: 8 May 2016
  3. eduar2083

    eduar2083 Miembro frecuente

    Registro:
    26 Jul 2011
    Mensajes:
    224
    Likes:
    46
    @CarCaBot, gracias por responder.
    Estoy llevando un curso de NodeJS + Bootstrap.
    Casi siempre utilizo Visual Studio ya que desarrollo en .Net y pues estoy acostumbrado a su intellisense.

    Hoy, deseo llevar este curso con Sublime Text y el problema es que no me muestra ninguna sugerencia de clases css de Bootstrap a pesar que el package que mencioné está instalado correctamente y he reiniciado el editor:
    [​IMG]

    Estaba pensando que talvez hay alguna combinación de teclas para mostrar las sugerencias.

    Saludos.
     
  4. CarCaBot

    CarCaBot Miembro maestro

    Registro:
    25 Nov 2011
    Mensajes:
    503
    Likes:
    215
    Yo cargo la version de sublime text2 que es compatible con casi todos los package, para la chamba que deseas hacer, yo prefiero que instales algunos paquetes llamados goto-css-declaration y Yui compressor si estas trabajando con un framework como bootstrap, luego el All autocomplete que es buenisimo para completar las syntaxis en archivos que estas trabajando, recordarte que es necesario tener los archivos abiertos con los que vas a trabajar dentro del sublime, ya que de otra forma no funcionan.

    Pero en el sublime text2 aun te digo que el package que tratas instalar me va bien en esa version del sublime, no sera por la version? si pruebas trabajar en el sublime text2?
     
    Última edición: 8 May 2016
  5. cholosoy

    cholosoy Miembro nuevo

    Registro:
    4 Jun 2009
    Mensajes:
    4
    Likes:
    0
    Haz probado el Visual Studio Code ? Es muy parecido al sublime, includso mejor y tiene el intelisense de VS full.