No se abre el centro de software(linux)

Publicado en 'GNU/Linux' por Chanox, 14 Jul 2015.





  1. Chanox

    Chanox Miembro frecuente

    Registro:
    16 Mar 2015
    Mensajes:
    156
    Likes:
    1




    Cuando abro el programa, ni se ejecuta, espero un rato y nada. Entonces intento abrirlo por terminar con "software-center" aparte de no ejecutarse el programa, me sale esto:

    Código:
    (software-center:3905): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:233:17: Expected a valid selector
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:538:12: Expected '('
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: button.css:41:13: Expected '('
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: button.css:46:29: Expected ',' in color definition
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: toolbar.css:34:23: Not a valid image
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: toolbar.css:90:22: Not a valid image
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: popover.css:27:4: Junk at end of value
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: popover.css:37:17: Expected '('
    
    (software-center:3905): Gtk-WARNING **: Theme parsing error: albumlistview.css:26:20: Not using units is deprecated. Assuming 'px'.
    2015-07-14 11:40:09,607 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
    2015-07-14 11:40:09,607 - root - ERROR - Could not find any typelib for Gst
    2015-07-14 11:40:09,654 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
    2015-07-14 11:40:09,658 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
    Traceback (most recent call last):
      File "/usr/bin/software-center", line 142, in <module>
        app = SoftwareCenterAppGtk3(datadir, xapian_base_path, options, args)
      File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 387, in __init__
        self.datadir)
      File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 78, in __init__
        self._get_emblems(self.icons)
      File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 192, in _get_emblems
        pb = icons.load_icon(emblem, self.ICON_SIZE, 0)
      File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
        return info.invoke(*args, **kwargs)
    gi._glib.GError: El icono «package-remove» no está presente en el tema
    
    He tratado de buscar alguna solución a específicamente mi problema pero solo veo otras cosas.. espero me puedan ayudar, gracias.

    uso elementary os

    bueno, ya solucioné el problema, era problema de los iconos, yo lo había cambiado por unos nuevos y bueno lo solucioné cambiando a como viene por default y se soluciona.
     
    Última edición: 14 Jul 2015