Script Backup automatico al email

Publicado en 'Redes Inalámbricas' por javierlaura, 13 Abr 2011.





  1. javierlaura

    javierlaura Miembro maestro

    Registro:
    15 Jul 2010
    Mensajes:
    473
    Likes:
    64




    Hola, en el mk de un amigo vi q tenia un script q hacia crear un backup automatico y a la vez q se lo envie a su correo a diario, pero me dijo q no solo es el script sino q tambien se configura ma cosas, pero qno sabe q cosas son pork su mk lo configuro otra persona, alguien como o sbe de esto?
    seria excelente si lo compartieran. saludos :yeah:
     


  2. jemersonalonso

    jemersonalonso Miembro maestro

    Registro:
    4 Mar 2010
    Mensajes:
    978
    Likes:
    305
  3. Leonardo

    Leonardo Miembro de bronce

    Registro:
    15 Mar 2011
    Mensajes:
    1,321
    Likes:
    195
    el gmail tiene esa opcion.
     
  4. javierlaura

    javierlaura Miembro maestro

    Registro:
    15 Jul 2010
    Mensajes:
    473
    Likes:
    64
    me pide poner el ip de un servidor SMTP, q es eso, no saber :cray:
     
  5. jemersonalonso

    jemersonalonso Miembro maestro

    Registro:
    4 Mar 2010
    Mensajes:
    978
    Likes:
    305

    Es un servidor de correo, ya sea gmail,hotmail,yahoo, el protocolo que empleen cada uno puede ser POP3 y/o IMAP

    Para GMAIL tiene
    Para Hotmail tiene
    Para Yahoo
     
  6. javierlaura

    javierlaura Miembro maestro

    Registro:
    15 Jul 2010
    Mensajes:
    473
    Likes:
    64

    ya lo hice andar, pero con hotmail no funka, con gmail si. gracias :yeah:
     
    Última edición: 13 Abr 2011
  7. milpecaditos

    milpecaditos Miembro maestro

    Registro:
    18 Nov 2010
    Mensajes:
    932
    Likes:
    167
    hey!! no se si sea pedir mucho pero puedes dar una manito con eso ?? o quisas puedas hacer un tuto ?? jeje yo intente y la verdad ya vole.... :oops:
     
  8. joemg6

    joemg6 Miembro maestro

    Registro:
    5 May 2010
    Mensajes:
    455
    Likes:
    198
    Primero tienes que tener una cuenta de correo en Gmail
    luego configurar en el mikrotik de la siguiente forma

    1.-Configurar en Tools - Email
    [​IMG]
    donde USUARIO es tu nombre de usuario de tu cuenta Gmail

    2.- Configurar el Script (reemplazar en el script USUARIO por el usuario de su cuenta Gmail)
    [​IMG]

    Script para la version de Mikrotik 3.30

    /system backup save name=([/system identity get name] . "-" . \
    [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); :delay 10; \
    /tool e-mail send to="USUARIO@gmail.com" subject=([/system identity get name] . " Backup " . \
    [/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :delay 10; \
    /file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup")]; \
    :log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])

    Script para la version Mikrotik 4.10

    /system backup save name=([/system identity get name] . "-" . \
    [:pick [/system clock get date] 7 11] . [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6]); :delay 10; \
    /tool e-mail send tls=yes to="USUARIO@gmail.com" subject=([/system identity get name] . " Backup " . \
    [/system clock get date]) file=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup"); :delay 10; \
    /file rem [/file find name=([/system identity get name] . "-" . [:pick [/system clock get date] 7 11] . \
    [:pick [/system clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup")]; \
    :log info ("System Backup emailed at " . [/sys cl get time] . " " . [/sys cl get date])


    3.- verificamos si ha enviado el backup al correo
    [​IMG]

    4.- configuramos en scheduler para que se ejecute automaticamente el script
    [​IMG]

    tambien hay otros scripts en la red, pero yo pongo aca los que use y me funciona :yeah:
     
    Última edición: 15 Abr 2011
    A NeNeCiLLO le gustó este mensaje.
  9. milpecaditos

    milpecaditos Miembro maestro

    Registro:
    18 Nov 2010
    Mensajes:
    932
    Likes:
    167
    joemg6 grande con el aporte gracias soy nuevo en esto y en este foro estoy aprendiendo mucho SALUDOS DESDE AREQUIPA!! :wow:
     
  10. NeNeCiLLO

    NeNeCiLLO Miembro de bronce

    Registro:
    14 Jun 2009
    Mensajes:
    1,042
    Likes:
    2
    creo que joemg6 lo dejo mas claro que el agua...
     
  11. milpecaditos

    milpecaditos Miembro maestro

    Registro:
    18 Nov 2010
    Mensajes:
    932
    Likes:
    167
    que extraño intente tal como esta en ese manual pero no me manda el back , quisas alguien tubo el mismo problema ....:errr:
     
  12. NeNeCiLLO

    NeNeCiLLO Miembro de bronce

    Registro:
    14 Jun 2009
    Mensajes:
    1,042
    Likes:
    2
    que raro milpecaditos acabo de hacerlo por curiosidad como esta en el manual y sale perfectamente bien... :w0w: por ahi hay algo que estas haciendo mal.... Buen manual joemg6 una vez mas...



    por cierto no toma mas de 5 minutos....
     
    Última edición: 17 Abr 2011